Booting genode/nova

Wolfgang Schmidt wolfgang.schmidt at ...243...
Sun Jun 15 18:38:34 CEST 2014


Hi Norman,

-----Urspr√ľngliche Nachricht----- 
From: Norman Feske
Sent: Friday, May 2, 2014 11:33 AM
To: genode-main at lists.sourceforge.net
Subject: Re: Booting genode/nova

>For testing, it is very helpful to have Genode's LOG output available,
>which is directed to the comport. Unfortunately, modern PCs don't have a
>comport anymore. However, on most Intel-based PCs, there exists a
>feature called AMT that allows for sending comport output over the
>network. If you are interested in exploring this, it is worthwhile to
>search for 'amtterm'.

Finally got the x201 you supposed and tried to configure amt.

I tried the following:
on the x201 enable AMT, setup a new user wolfgang with password and enable 
SOL. I set a IP4 adress of 10.1.1.2. With the username and password i can 
log into the AMT web site of the computer.

On a hp i tried the commands from 
http://genode.org/documentation/release-notes/13.05 (On the client i 
installed amtterm 1.3 from repository.)
export AMT_TEST_MACHINE_IP=10.1.1.2
export AMT_TEST_MACHINE_PWD=Test$$44$$ (yep i know, but the machine cannot 
connect to the outside world)

and tried
RUN_OPT="--target amt" make run/printf

The x201 does not seem to get touched - even with disconnected network cable 
the test is succesful.

I honestly does not understand amt. I tried to use amtterm instead to try 
out the connection. With amtterm i get a "amtterm: AUTH - ERROR (failure) 
amtterm: ERROR: session authentification failed". I know that amtterm has 
nothing to do with genode directly, but if you are using it could you give a 
hint for the right direction?

Best regards,
Wolfgang 





More information about the users mailing list